Troubleshoot Issues in Noetix Search
This section provides information about commonly occurring issues with Noetix Search and steps for resolving them.
Problem statement
No information displayed on details page of Noetix Search running on Linux.
Symptom
When you access the details page of any object in Noetix Search, an error message similar to the following is displayed: “Error: Unable to query index at http://localhost/noetixsearch/solr. Please verify your Noetix configuration settings.”
Cause
This issue occurs when an incorrect Apache Tomcat port number is specified during Noetix Search installation. Consequently, Noetix Search is not able to query data from the search index.
Solution
To resolve this issue, do one of the following:
Edit the noetixsearch.xml and noetixsearch#export.xml configuration files and specify the correct Noetix Search Server URL. These files are located in the <Noetix Search installation directory>\Tomcat\conf\Catalina\localhost folder.
Reinstall Noetix Search and provide the correct Apache Tomcat port number.
Problem statement
Organization chart for views is not displayed.
Symptom
When you access a Noetix Search instance for Noetix Views (NoetixViews) in Microsoft Internet Explorer and click the organization chart icon for a view, the chart may not be displayed. Instead, the “loading please wait” message appears indefinitely.
Cause
This issue occurs when the chart is viewed in an Internet Explorer window that is maximized and at the 100% zoom level.
Solution
To resolve this issue, do one of the following:
Resize the browser window till the organization chart is displayed correctly.
Adjust the zoom level of the browser window till the organization chart is displayed correctly.
Open the organization chart in another browser, such as Google Chrome.