Troubleshooting NoetixViews Workbench
This chapter provides information on how to troubleshoot issues with the installation, repair, or upgrade of the Noetix Views Workbench (NoetixViews Workbench).
Troubleshoot Installation, Repair, Upgrade
This section provides information about commonly occurring issues with the installation, repair, or upgrade of the NoetixViews Workbench and steps for resolving them.
Problem Statement
NoetixViews Workbench will not work correctly after installation completes with an error message.
Symptom
Sometimes, when installing the NoetixViews Workbench, you may receive an error message similar to the following: “An error occurred during the configuration of the NoetixViews Workbench pages. Setup will not complete successfully.” The installation process will be completed when you click OK in the error message. However, the NoetixViews Workbench will not work correctly.
Solution
To work around this issue, uninstall the NoetixViews Workbench. Then, reinstall the software using the delay and retry command-line parameters as mentioned in the following procedure:
At the command prompt, navigate to the folder that contains the NoetixViews Workbench Setup program.
TypeWorkbench-<version>-windows-x64 --delay <delay value> --retry <retry value>, and press ENTER. The Setup will start.
The <version> placeholder specifies the NoetixViews Workbench version. The <delay value> placeholder specifies the time in seconds that the Setup will wait for the required component to deploy before configuring a web page with the component. The default value is 30 seconds; you must provide a value that is greater than 30. The <retry value> placeholder specifies how often the Setup will try to redeploy the component with the delay if the previous attempt failed. The default value is 1. For example, you can type Workbench-1.1.207.0-windows-x64 --delay 45 --retry 3 at the command prompt. If no values are specified, the default values will be used. If all the specified attempts fail, repeat the procedure with different parameters.
Problem Statement
Installation, repair, or upgrade of the NoetixViews Workbench fails.
Symptom
The setup aborts with an error message similar to the following: “Upgrade script failed. Installation aborted. Check log files for detail.”
Additionally, an error message similar to the following will be logged in the installation log at the “<version> Upgrade Script failed. Installation Aborted - RETURN CODE = <return code>. Check lst files under <lst files location>.”
Cause
The installation or upgrade setup fails on account of database-related issues, such as inadequate tablespace allocation or loss of connectivity to the database.
Solution
To solve this issue, identify and fix the database-related issues, if any, that may have been logged in the logs mentioned in the installation log at the <installation folder>\Noetix\Noetix Enterprise Manager\Cartridges\NoetixViewsWorkbench location.
Problem Statement
Upgrade of NoetixViews Workbench from versions prior to 2.2 fails.
Symptom
When you upgrade the NoetixViews Workbench from versions prior to 2.2, the upgrade process will fail with an error message similar to the following: “Unable to convert some revisions to the new data model. Installation Aborted. Check the log file for details. Contact Magnitude Software Support for assistance.”
Cause
The upgrade process fails when some view revisions cannot be converted due to validation constraints.
Solution
To resolve this issue, identify the affected view revisions by checking the log files, manually fix the issues with the revisions, and rerun the upgrade process. For help with this issue, contact insightsoftwareSupport. The error messages can be found in the installation log at the <installation folder>\Noetix\Noetix Enterprise Manager\Cartridges\NoetixViewsWorkbench location.