Skip to main content
insightsoftware Documentation insightsoftware Documentation
{%article.title%}
Published:
Was this article helpful?
0 out of 0 found this helpful

Work with Angles for Oracle-Generator for Tableau

Overview

This chapter provides information about how to use the Angles for Oracle Generator.

In This Chapter

The topics available in this chapter are as follows:

Configure Noetix Connection

What Is Noetix Connection?

A Noetix connection stores the connection information for a NoetixViews or Noetix Analytics data source and provides access to the NoetixViews or Noetix Analytics metadata. The Angles for Oracle Generator. will use the Noetix connection to access and load the NoetixViews or Noetix Analytics metadata. For information about setting up data sources, see the chapter “Set Up Data Source” in the Angles for Oracle Generator for Tableau Administrator Guide.

Creating Noetix Connection

The following step-action table contains the procedure for creating a Noetix connection.

Step

Action

1.

Select Start > All Programs > Angles for Oracle Generator for Tableau > Angles for Oracle Generator for Tableau. The Angles for Oracle Generator for Tableau window will appear.

2.

In the Create Tableau Data Source area, select Configure Noetix Connections. The Angles for Oracle Generator for Tableau dialog box will appear.

3.

Select New. The options to specify details for the Noetix connection will appear in the dialog box.

4.

In the Name box, type a unique name for the Noetix connection that you want to create for the NoetixViews or Noetix Analytics data source.

5.

In the Server box, accept the default value or type the URL of the computer on which the Angles for Oracle Generator Service is installed.

The URL should be provided in the net.tcp://[computer_name/IP_address:port] format.

6.

In the Source list box, select a NoetixViews or Noetix Analytics data source.

Contact the administrator if the list is empty or the required data source is not available in the list.

7.

Select OK. The Noetix connection will be displayed on the Angles for Oracle Generator for Tableau window in the Create Tableau Data Source area.

Create Tableau Data Source

Overview

This topic contains the step-action table for creating a Tableau data source for the NoetixViews and Noetix Analytics metadata.

Creating Tableau Data Source

The following step-action table contains the procedure for creating a Tableau data source.

Step

Action

1.

Select Start > All Programs > Angles for Oracle Generator for Tableau > Angles for Oracle Generator for Tableau. The Angles for Oracle Generator for Tableau window will appear.

2.

In the Create Tableau Data Source area, select the Noetix connection for NoetixViews or Noetix Analytics. The corresponding metadata will be loaded, and the main window of the Angles for Oracle Generator will appear.

3.

In the left pane, expand the tree, and select the required metadata objects. The selected objects corresponding to the Noetix views or Noetix Analytics field definition folders are displayed in the right pane, and in the left pane, the tree is automatically modified so that only related objects are displayed.

4.

Optionally, to see the description of a metadata object, move the pointer over the object.

5.

To specify filters, select Edit Filters.The Data Filters window appears. Otherwise, go to step 7. Alternatively, on the File menu, select Edit Filters. The Data Filters window will appear.

For a Noetix Analytics data warehouse that is hosted on a Microsoft SQL Server database, if Windows-based authentication is not configured for the data source, when you specify filters, you will be prompted to provide the NOETIXRPT password.

6.

Perform the following steps:

  1. In the Available fields list, select the required fields, and then select . The selected fields will appear in the right pane. The operator and values for a filter will be available for selection only after the list is populated with values.
  2. To remove a filter, select for the filter.

  3. In the Filters pane, choose the appropriate operator and value for the filters.
  4. Optionally, type a search string, and refresh the list. The values that begin with the letters in the search string will be displayed.
  5. Select OK. The information about the applied filters for the selected metadata objects will be displayed in the right pane that contains the entity-relationship diagram (ERD).

7.

Select Save. The Save As dialog box will be displayed.

8.

Provide a name for the Tableau data source file, and save it. By default, the file will be saved in the following Tableau data source repository folder: \Users\<user name>\Documents\My Tableau Repository\Datasources. The name of the Tableau data source with the path will be displayed on the title bar of the main window of the Angles for Oracle Generator.

9.

Perform one of the following steps to open the Tableau data source file in the Tableau Desktop:

  • On the main window of the Angles for Oracle Generator, select Open in Tableau.
  • On the File menu of the main window of the Angles for Oracle Generator, select Open in Tableau Desktop.
  • Start the Tableau Desktop, and open the Tableau data source file.

Modify Tableau Data Source

Overview

This topic contains the step-action table for modifying a Tableau data source for the NoetixViews and Noetix Analytics metadata.

Modifying Tableau Data Source

The following step-action table contains the procedure for modifying a Tableau data source.

Step

Action

1.

Select Start > All Programs > Angles for Oracle Generator for Tableau > Angles for Oracle Generator for Tableau. The Angles for Oracle Generator for Tableau window appears. The most recently saved or opened Tableau data sources will be displayed in the Edit Tableau Data Source area.

2.

In the Edit Tableau Data Source area, perform one of the following steps:

  • In the list of available Tableau data sources, select the required Tableau data source.
  • Select Browse, navigate to the location where the Tableau data source file is saved, select it, and then select Open.

The Tableau data source file will be opened in the main window of the Angles for Oracle Generator.

3.

Make the necessary modifications to the Tableau data source.

insightsoftware recommends that modifications to the Tableau data source, such as the addition of filters and hierarchies, be made only through Angles for Oracle Generator whenever possible. Modifications made to the Tableau data source with the use of the Tableau Desktop may not be compatible with the Angles for Oracle Generator.

4.

On the File menu, select Save. The Save As dialog box will be displayed. The Tableau data source file along with the default path of the file will be displayed in the File name box.

5.

Perform the following steps:

  1. After verifying the location where you want to save the Tableau data source, select Save.
  2. When you are prompted to replace the existing file, select Yes. The existing Tableau data source will be replaced with the modified Tableau data source.

6.

Perform one of the following steps to open the Tableau data source file in the Tableau Desktop:

  • On the main window of the Angles for Oracle Generator, select Open in Tableau.
  • On the File menu of the main window of the Angles for Oracle Generator, select Open in Tableau Desktop.
  • Start the Tableau Desktop, and open the Tableau data source file.

Handling of Metadata in Angles for Oracle Generator

Handling of Hierarchies

In the (Undefined variable: General.ProductShortName), hierarchies pertaining to NoetixViews or Noetix Analytics are defined as ordered sets of columns within individual views or relationship sets representing drill paths. When two or more columns of any hierarchy are selected in the Angles for Oracle Generator, the hierarchy information will be configured in the Tableau data source.

Handling of Chasm Trap

The Angles for Oracle Generator. enables you to avoid the chasm trap, in which two unrelated fact tables are joined by a shared conformed dimension. When you select a fact table in the Angles for Oracle Generator., unrelated fact tables will be hidden. Therefore, for every Tableau data source, there will be only one primary fact table, and the entity-relationship diagram (ERD) will be displayed as a snowflake or star schema. For example, the following screen shot shows the views listed in the Angles for Oracle Generator. for a NoetixViews data source.

When you select a view, only the related views will be displayed in the Angles for Oracle Generator as shown in the following screenshot.

Handling of Fan Trap

The Angles for Oracle Generator. enables you to avoid the fan trap. When multiple fact tables that have joins are selected, performing aggregations on measures of the intermediate fact tables can result in incorrect measure values. When you select multiple fact tables in the insightsoftware, the measures in the intermediate fact tables will show up as dimensions in the Tableau Desktop.

For example, the following screenshot displays the GL Details ODS relationship set with two fact tables selected, GL Details and GL Batch Headers Details, for a Noetix Analytics data source.

When you open the saved Tableau data source file in the Tableau Desktop, the measures in the intermediate fact table, GL Batch Headers Details, will be displayed as dimensions.

Published:

Work with Angles for Oracle-Generator for Tableau

Overview

This chapter provides information about how to use the Angles for Oracle Generator.

In This Chapter

The topics available in this chapter are as follows:

Configure Noetix Connection

What Is Noetix Connection?

A Noetix connection stores the connection information for a NoetixViews or Noetix Analytics data source and provides access to the NoetixViews or Noetix Analytics metadata. The Angles for Oracle Generator. will use the Noetix connection to access and load the NoetixViews or Noetix Analytics metadata. For information about setting up data sources, see the chapter “Set Up Data Source” in the Angles for Oracle Generator for Tableau Administrator Guide.

Creating Noetix Connection

The following step-action table contains the procedure for creating a Noetix connection.

Step

Action

1.

Select Start > All Programs > Angles for Oracle Generator for Tableau > Angles for Oracle Generator for Tableau. The Angles for Oracle Generator for Tableau window will appear.

2.

In the Create Tableau Data Source area, select Configure Noetix Connections. The Angles for Oracle Generator for Tableau dialog box will appear.

3.

Select New. The options to specify details for the Noetix connection will appear in the dialog box.

4.

In the Name box, type a unique name for the Noetix connection that you want to create for the NoetixViews or Noetix Analytics data source.

5.

In the Server box, accept the default value or type the URL of the computer on which the Angles for Oracle Generator Service is installed.

The URL should be provided in the net.tcp://[computer_name/IP_address:port] format.

6.

In the Source list box, select a NoetixViews or Noetix Analytics data source.

Contact the administrator if the list is empty or the required data source is not available in the list.

7.

Select OK. The Noetix connection will be displayed on the Angles for Oracle Generator for Tableau window in the Create Tableau Data Source area.

Create Tableau Data Source

Overview

This topic contains the step-action table for creating a Tableau data source for the NoetixViews and Noetix Analytics metadata.

Creating Tableau Data Source

The following step-action table contains the procedure for creating a Tableau data source.

Step

Action

1.

Select Start > All Programs > Angles for Oracle Generator for Tableau > Angles for Oracle Generator for Tableau. The Angles for Oracle Generator for Tableau window will appear.

2.

In the Create Tableau Data Source area, select the Noetix connection for NoetixViews or Noetix Analytics. The corresponding metadata will be loaded, and the main window of the Angles for Oracle Generator will appear.

3.

In the left pane, expand the tree, and select the required metadata objects. The selected objects corresponding to the Noetix views or Noetix Analytics field definition folders are displayed in the right pane, and in the left pane, the tree is automatically modified so that only related objects are displayed.

4.

Optionally, to see the description of a metadata object, move the pointer over the object.

5.

To specify filters, select Edit Filters.The Data Filters window appears. Otherwise, go to step 7. Alternatively, on the File menu, select Edit Filters. The Data Filters window will appear.

For a Noetix Analytics data warehouse that is hosted on a Microsoft SQL Server database, if Windows-based authentication is not configured for the data source, when you specify filters, you will be prompted to provide the NOETIXRPT password.

6.

Perform the following steps:

  1. In the Available fields list, select the required fields, and then select . The selected fields will appear in the right pane. The operator and values for a filter will be available for selection only after the list is populated with values.
  2. To remove a filter, select for the filter.

  3. In the Filters pane, choose the appropriate operator and value for the filters.
  4. Optionally, type a search string, and refresh the list. The values that begin with the letters in the search string will be displayed.
  5. Select OK. The information about the applied filters for the selected metadata objects will be displayed in the right pane that contains the entity-relationship diagram (ERD).

7.

Select Save. The Save As dialog box will be displayed.

8.

Provide a name for the Tableau data source file, and save it. By default, the file will be saved in the following Tableau data source repository folder: \Users\<user name>\Documents\My Tableau Repository\Datasources. The name of the Tableau data source with the path will be displayed on the title bar of the main window of the Angles for Oracle Generator.

9.

Perform one of the following steps to open the Tableau data source file in the Tableau Desktop:

  • On the main window of the Angles for Oracle Generator, select Open in Tableau.
  • On the File menu of the main window of the Angles for Oracle Generator, select Open in Tableau Desktop.
  • Start the Tableau Desktop, and open the Tableau data source file.

Modify Tableau Data Source

Overview

This topic contains the step-action table for modifying a Tableau data source for the NoetixViews and Noetix Analytics metadata.

Modifying Tableau Data Source

The following step-action table contains the procedure for modifying a Tableau data source.

Step

Action

1.

Select Start > All Programs > Angles for Oracle Generator for Tableau > Angles for Oracle Generator for Tableau. The Angles for Oracle Generator for Tableau window appears. The most recently saved or opened Tableau data sources will be displayed in the Edit Tableau Data Source area.

2.

In the Edit Tableau Data Source area, perform one of the following steps:

  • In the list of available Tableau data sources, select the required Tableau data source.
  • Select Browse, navigate to the location where the Tableau data source file is saved, select it, and then select Open.

The Tableau data source file will be opened in the main window of the Angles for Oracle Generator.

3.

Make the necessary modifications to the Tableau data source.

insightsoftware recommends that modifications to the Tableau data source, such as the addition of filters and hierarchies, be made only through Angles for Oracle Generator whenever possible. Modifications made to the Tableau data source with the use of the Tableau Desktop may not be compatible with the Angles for Oracle Generator.

4.

On the File menu, select Save. The Save As dialog box will be displayed. The Tableau data source file along with the default path of the file will be displayed in the File name box.

5.

Perform the following steps:

  1. After verifying the location where you want to save the Tableau data source, select Save.
  2. When you are prompted to replace the existing file, select Yes. The existing Tableau data source will be replaced with the modified Tableau data source.

6.

Perform one of the following steps to open the Tableau data source file in the Tableau Desktop:

  • On the main window of the Angles for Oracle Generator, select Open in Tableau.
  • On the File menu of the main window of the Angles for Oracle Generator, select Open in Tableau Desktop.
  • Start the Tableau Desktop, and open the Tableau data source file.

Handling of Metadata in Angles for Oracle Generator

Handling of Hierarchies

In the (Undefined variable: General.ProductShortName), hierarchies pertaining to NoetixViews or Noetix Analytics are defined as ordered sets of columns within individual views or relationship sets representing drill paths. When two or more columns of any hierarchy are selected in the Angles for Oracle Generator, the hierarchy information will be configured in the Tableau data source.

Handling of Chasm Trap

The Angles for Oracle Generator. enables you to avoid the chasm trap, in which two unrelated fact tables are joined by a shared conformed dimension. When you select a fact table in the Angles for Oracle Generator., unrelated fact tables will be hidden. Therefore, for every Tableau data source, there will be only one primary fact table, and the entity-relationship diagram (ERD) will be displayed as a snowflake or star schema. For example, the following screen shot shows the views listed in the Angles for Oracle Generator. for a NoetixViews data source.

When you select a view, only the related views will be displayed in the Angles for Oracle Generator as shown in the following screenshot.

Handling of Fan Trap

The Angles for Oracle Generator. enables you to avoid the fan trap. When multiple fact tables that have joins are selected, performing aggregations on measures of the intermediate fact tables can result in incorrect measure values. When you select multiple fact tables in the insightsoftware, the measures in the intermediate fact tables will show up as dimensions in the Tableau Desktop.

For example, the following screenshot displays the GL Details ODS relationship set with two fact tables selected, GL Details and GL Batch Headers Details, for a Noetix Analytics data source.

When you open the saved Tableau data source file in the Tableau Desktop, the measures in the intermediate fact table, GL Batch Headers Details, will be displayed as dimensions.

For an optimal Community experience, Please view on Desktop
Powered by Zendesk